给wamp3.0.6自定义php版本和数据库版本

自定义数据库版本

去下载Mysql的zip包,我下载的是Mariadb10.2的包.

Mariadb数据库完全兼容Mysql,他是mysql的一个分支.

将下载好的zip包解压到wamp的bin/mysql目录下.

将解压出来的目录名前面加一个mysql,否则wamp不识别

将wamp自带的mysql目录下的wampserver.conf文件拷贝到新的mysql目录下面

将my.ini的25行作用添加一句

; The MySQL server
[wampmysqld64]

my.ini是修改"my-任意.ini"文件而来的,这是针对Mariadb

mysql目录并没有这些文件,可以尝试复制自带的mysql目录下面的my.ini

自定义PHP版本

下载php的zip包,注意下载Thread Safe(安全版)的php包.

非安全的包是给nginx使用的

将下载的phpZIP包解压到wamp的bin/php目录下

拷贝自带php版本的wampserver.conf文件到新的PHP目录下

拷贝自带php版本的phpForApache.ini到新的php目录下,记得更改这个文件里面的目录地址

(建议拷贝自带的php7.0.10文件)

然后再次打开wamp选择新的php版本和新的mysql版本就可以了

分享 二维码
分类:记录
标签:
还没有评论


在此输入评论..
0/100